Faspex patch for Internet Explorer 11 support

Description

When attempting to transfer a file using Faspex in Internet Explorer 11, the web page may complain that the Connect plug-in is not installed on the system. This is due to a change made to the agent string supplied to Faspex by Internet Explorer. 

Environment

  • Product: Faspex
  • Version: 3.5 or earlier
  • Operating system: Windows or Linux

Solution

This issue is resolved in Faspex 3.7 or later. For Faspex 3.5, the following patch can be used on the server:

Installation

1. Back up the following file in the Faspex install directory:

  • Windows: 'C:\Program Files (x86)\Aspera\Faspex\public\javascripts\asperaweb.js'
  • Linux: /opt/aspera/faspex//public/javascripts/asperaweb.js

2. Extract the contents of this ZIP file to a temporary directory.

 

3. Backup the original file(listed in step 1) and move in the new asperaweb.js file exported from the zip.

 

4. Change the file permissions and ownership of the extracted files to match the original files.

5. At the command line, enter "asctl faspex:restart" to restart faspex.

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk