Moving your Enterprise Server/Connect Server/P2P/Client installation to a new Windows machine

Description

This article describes how to move your transfer server, P2P or Client installation to a Windows system.

Follow the instructions below based on the system that the original, existing installation is located on.

Windows to Windows

1. Export connections

If you make use of the GUI application for your product and would like to transfer the saved connections to the new machine, you will need to export the connections to a file.

For each user on the system you would like to export connections for, follow the exporting and file saving steps in the following Knowledge Base article: How to Export and Import Connections. You can choose to export all or only a chosen selection of connections.

Shared connections do not need to be exported as they are moved with files in a later step. Therefore, you only need to export connections that individual users have saved for themselves.

2. Move files to the new Windows system

You are now ready to move files from your old machine to the new one. Copy over the following files to a temporary directory on your new Windows machine:

  • C:\Program Files (x86)\Aspera\product_name\etc\aspera.conf
  • C:\Program Files (x86)\Aspera\product_name\etc\aspera-license
  • C:\Program Files (x86)\Aspera\product_name\etc\ui.conf
  • the exported connection files
  • (if you use Pre-Post scripts) C:\Program Files (x86)\Aspera\product_name\var\aspera-prepost.bat and any other scripts it calls
  • (if you use Hot Folders) C:\Program Files (x86)\Aspera\product_name\etc\sync-conf.xml

Note: You cannot use the same license on multiple systems as this is a violation of your license terms.

You may use the license from your original system on your new system if you will be uninstalling your Aspera product on the original system right away. For more information on where your license is located, see this article.

If your original product installation needs to stay up and running for a short period, you may ask your account manager for a temporary license to use on your new installation.

3. Prepare your new Windows system

The rest of the instructions apply to the new Windows machine. On the new Windows machine, make sure of the following:

  • The product is installed for which you are moving files
  • Your new Windows system has the same system users that your previous system had and used as transfer users

For example, if your original installation of ES used transfer users janedoe, hpotter and aspera, your new Windows system must also have the users janedoe, hpotter and aspera.

To add a user, open the Control Panel and go to User Accounts and Family Safety > Add or remove user accounts > Create a new account.

If you can’t recall all the transfer users your previous system used, you can look at the aspera.conf file in the <users> section. It can be found in the files you copied to a temporary directory:

  • C:\path\to\temp\aspera.conf

4. Stop services and transfers

Close the product GUI application if it is open, and make sure any transfers have stopped.

Stop services by opening the Control Panel and going to System and Security > Administrative Tools > Services. Right click on the following services and select Stop:

  • Aspera NodeD
  • Aspera HTTPD
  • Aspera Central
  • Apera Sync

5. Move the files of the old machine to their proper locations.

You can use the commands below to copy the files to their proper locations:

> for %I in (C:\path\to\temp\aspera.conf C:\path\to\temp\aspera-license C:\path\to\temp\ui.conf) do copy %I C:\Program Files (x86)\Aspera\product_name\etc

## if you use Pre-Post ##
> copy C:\path\to\temp\aspera-prepost.bat C:\path\to\temp\script1 C:\path\to\temp\script2 ... C:\Program Files (x86)\Aspera\product_name\var\aspera-prepost

6. Import connections

If you exported connections from your previous machine (step 1), you will need to import them for your users. For each user on the system you would like to import connections for, follow the importing steps in the following Knowledge Base article: How to Export and Import Connections.

7. Enable your transfer users

Because Windows does not natively support SSH for system accounts, you need to generate the necessary configuration files which don’t yet exist for your users.

In the top menu of your product’s GUI application, go to Help > Troubleshoot. The troubleshooter may report finding two problems (the missing configuration files) and no fixes, but this action generates the necessary files for you. Close the GUI application and reopen it so you can see your users.

8. Import Hot Folders

If you had Hot Folders on your previous Windows system, you can now import them into the new system.

Move the sync-conf.xml file to its proper location. You can use the following command:

> copy C:\path\to\temp\sync-conf.xml C:\Program Files (x86)\Aspera\product_name\etc

If the source directory paths of your Hot Folders are different on the new Windows system, you will have to modify this file.

In sync-conf.xml, you will need to modify the <LDIR> value within each <SYNC_PAIR>, if the source path has changed.

9. Modify configurations if necessary

Double check your configurations to ensure that they apply to your new machine. For example, docroot, bandwidth and network settings may need to be modified.

For your transfer users, the docroot path may or may not be the same on your new system. You can change this and other settings either through the GUI, the command line tool asconfigurator or directly through aspera.conf.

Note that if your transfer server interacts with a web application, you will need to change the IP address in aspera.conf in the <server> section to the address of your new Windows system.

10. Restart services

Start services by opening the Control Panel and going to System and Security > Administrative Tools > Services. Right click on the following services and select Start:

  • Aspera NodeD
  • Aspera Central
  • Apera Sync

11. You have now finished moving your installation from a Windows to a new Windows system

Linux to Windows

1. Export connections

If you make use of the GUI application for your product and would like to transfer the saved connections to the new machine, you will need to export the connections to a file.

For each user on the system you would like to export connections for, follow the exporting and file saving steps in the following Knowledge Base article: How to Export and Import Connections. You can choose to export all or only a chosen selection of connections.

Shared connections do not need to be exported as they are moved with files in a later step. Therefore, you only need to export connections that individual users have saved for themselves.

2. Move files to the new Windows system

You are now ready to move files from your old machine to the new one. Copy over the following files to a temporary directory on your new Windows machine:

  • /opt/aspera/etc/aspera.conf
  • /opt/aspera/etc/aspera-license
  • /opt/aspera/etc/ui.conf
  • the exported connection files
  • (if you use Pre-Post scripts) /opt/aspera/var/aspera-prepost and any other scripts it calls
Note: If you use Pre-Post scripts you will need to adjust any Bash scripting to a Windows-compatible script (batch, Perl if it is installed on your Windows, and so on).

3. Prepare your new Windows system

The rest of the instructions apply to the new Windows machine. On the new Windows machine, make sure of the following:

  • The product is installed for which you are moving files
  • Your new Windows system has the same system users that your previous system had and used as transfer users

For example, if your original installation of ES used transfer users janedoe, hpotter and aspera, your new Windows system must also have the users janedoe, hpotter and aspera.

To add a user, open the Control Panel and go to User Accounts and Family Safety > Add or remove user accounts > Create a new account.

If you can’t recall all the transfer users your previous system used, you can look at the aspera.conf file in the <users> section. It can be found in the files you copied to a temporary directory:

  • C:\path\to\temp\aspera.conf

4. Stop services and transfers

Close the product GUI application if it is open, and make sure any transfers have stopped.

Stop services by opening the Control Panel and going to System and Security > Administrative Tools > Services. Right click on the following services and select Stop:

  • Aspera NodeD
  • Aspera HTTPD
  • Aspera Central
  • Apera Sync

5. Move the files of the old machine to their proper locations.

You can use the commands below to copy the files to their proper locations:

> for %I in (C:\path\to\temp\aspera.conf C:\path\to\temp\aspera-license C:\path\to\temp\ui.conf) do copy %I C:\Program Files (x86)\Aspera\product_name\etc

## if you use Pre-Post ##
> copy C:\path\to\temp\aspera-prepost.bat C:\path\to\temp\script1 C:\path\to\temp\script2 ... C:\Program Files (x86)\Aspera\product_name\var\aspera-prepost

6. Import connections

If you exported connections from your previous machine (step 1), you will need to import them for your users. For each user on the system you would like to import connections for, follow the importing steps in the following Knowledge Base article: How to Export and Import Connections.

7. Enable your transfer users

Because Windows does not natively support SSH for system accounts, you need to generate the necessary configuration files which don’t yet exist for your users.

In the top menu of your product’s GUI application, go to Help > Troubleshoot. The troubleshooter may report finding two problems (the missing configuration files) and no fixes, but this action generates the necessary files for you. Close the GUI application and reopen it so you can see your users.

8. Modify configurations if necessary

Double check your configurations to ensure that they apply to your new machine. For example, docroot, bandwidth and network settings may need to be modified.

For your transfer users, the docroot path is likely not the same on your new system since you are moving from Linux. You can change this and other settings either through the GUI, the command line tool asconfigurator or directly through aspera.conf.

Note that if your transfer server interacts with a web application, you will need to change the IP address in aspera.conf in the <server> section to the address of your new Windows system.

9. Restart services

Start services by opening the Control Panel and going to System and Security > Administrative Tools > Services. Right click on the following services and select Start:

  • Aspera NodeD
  • Aspera Central
  • Apera Sync

10. You have now finished moving your installation from Linux to a new Windows system

Mac to Windows

1. Export connections

If you make use of the GUI application for your product and would like to transfer the saved connections to the new machine, you will need to export the connections to a file.

For each user on the system you would like to export connections for, follow the exporting and file saving steps in the following Knowledge Base article: How to Export and Import Connections. You can choose to export all or only a chosen selection of connections.

Shared connections do not need to be exported as they are moved with files in a later step. Therefore, you only need to export connections that individual users have saved for themselves.

2. Move files to the new Windows system

You are now ready to move files from your old machine to the new one. Copy over the following files to a temporary directory on your new Windows machine:

  • /Library/Aspera/etc/aspera.conf
  • /Library/Aspera/etc/aspera-license
  • /Library/Aspera/etc/ui.conf
  • the exported connection files
  • (if you use Pre-Post scripts) /Library/Aspera/var/aspera-prepost and any other scripts it calls
Note: If you use Pre-Post scripts you will need to adjust any Bash scripting to a Windows-compatible script (batch, Perl if it is installed on your Windows, and so on).

3. Prepare your new Windows system

The rest of the instructions apply to the new Windows machine. On the new Windows machine, make sure of the following:

  • The product is installed for which you are moving files
  • Your new Windows system has the same system users that your previous system had and used as transfer users

For example, if your original installation of ES used transfer users janedoe, hpotter and aspera, your new Windows system must also have the users janedoe, hpotter and aspera.

To add a user, open the Control Panel and go to User Accounts and Family Safety > Add or remove user accounts > Create a new account.

If you can’t recall all the transfer users your previous system used, you can look at the aspera.conf file in the <users> section. It can be found in the files you copied to a temporary directory:

  • C:\path\to\temp\aspera.conf

4. Stop services and transfers

Close the product GUI application if it is open, and make sure any transfers have stopped.

Stop services by opening the Control Panel and going to System and Security > Administrative Tools > Services. Right click on the following services and select Stop:

  • Aspera NodeD
  • Aspera HTTPD
  • Aspera Central
  • Apera Sync

5. Move the files of the old machine to their proper locations.

You can use the commands below to copy the files to their proper locations:

> for %I in (C:\path\to\temp\aspera.conf C:\path\to\temp\aspera-license C:\path\to\temp\ui.conf) do copy %I C:\Program Files (x86)\Aspera\product_name\etc

## if you use Pre-Post ##
> copy C:\path\to\temp\aspera-prepost.bat C:\path\to\temp\script1 C:\path\to\temp\script2 ... C:\Program Files (x86)\Aspera\product_name\var\aspera-prepost

6. Import connections

If you exported connections from your previous machine (step 1), you will need to import them for your users. For each user on the system you would like to import connections for, follow the importing steps in the following Knowledge Base article: How to Export and Import Connections.

7. Enable your transfer users

Because Windows does not natively support SSH for system accounts, you need to generate the necessary configuration files which don’t yet exist for your users.

In the top menu of your product’s GUI application, go to Help > Troubleshoot. The troubleshooter may report finding two problems (the missing configuration files) and no fixes, but this action generates the necessary files for you. Close the GUI application and reopen it so you can see your users.

8. Modify configurations if necessary

Double check your configurations to ensure that they apply to your new machine. For example, docroot, bandwidth and network settings may need to be modified.

For your transfer users, the docroot path is likely not the same on your new system since you are moving from Mac. You can change this and other settings either through the GUI, the command line tool asconfigurator or directly through aspera.conf.

Note that if your transfer server interacts with a web application, you will need to change the IP address in aspera.conf in the <server> section to the address of your new Windows system.

9. Restart services

Start services by opening the Control Panel and going to System and Security > Administrative Tools > Services. Right click on the following services and select Start:

  • Aspera NodeD
  • Aspera Central
  • Apera Sync

10. You have now finished moving your installation from a Mac to a new Windows system

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk